Page archived courtesy of the Geocities Archive Project https://www.geocitiesarchive.org
Please help us spread the word by liking or sharing the Facebook link below :-)


DSL (Damn Small Linux) on a Toshiba Satellite Pro 440CDX Laptop with Addtron EP-210 PCMCIA Ethernet card

These are some notes that may help get DSL runnning on a Toshiba Satellite Pro 440CDX Laptop with Addtron EP-210 PCMCIA Ethernet card (or similar NE2000 Compatible). My 440CDX has 32 MB RAM, 1 GB HD with Windows 98SE on first partition, a data partition, and a 64 MB linux swap partition.

1) Copy the file KNOPPIX from the DSL CD into a folder KNOPPIX at the root of a partition on HD e.g. C:\KNOPPIX\KNOPPIX is the full path to the file in DOS or /mnt/hda1/knoppix/knoppix in DSL.

My 440CDX has no CD-ROM. Since I have a router with DHCP, I used tomsrtbt on the 440CDX, and NFS on Linux on a desktop computer. On the desktop computer at 192.168.0.100 in my home LAN, export the cdrom, then on the 440CDX:

mount -t nfs 192.168.0.100:/cdrom /cdrom

then copy the KNOPPIX file.

Alternatives to the above include using a "Laplink" or "null" parallel printer cable, and PLIP or DOS interlnk & intersvr. Another approach would be to temporarily install the laptop HD into another computer with a CD-ROM drive.

2) There is a Toshiba BIOS setting: "PC Card Controller Mode" which has to be set to PCIC for the Addtron EP-210. The other choice is Cardbus which works for 3com Fast Etherlink XL PC Card 3c575-TX, for example.

It is tricky getting into the Toshiba BIOS. Tap the esc key just after power on, before the memory check. It may take a few reboots and attempts before success. Then 2 lines of text appear. Press F1. The card mode setting is on the lower right hand side of the first screen.

3) Boot DSL from floppy with (for my 440CDX):

dsl vga=normal fromhd

If you need more detail in a specific area, please e-mail me at ab876cd AT yahoo DOT ca

Dave

DSL (Damn Small Linux)

-----------------------------------------------------------
The info below may help install other versions of Linux. 
Sound is not working and I have not tried to get it working.

Script started on Mon Oct 17 20:50:38 2005
root@box:~# lsmod
Module                  Size  Used by    Not tainted
soundcore               3428   0 (autoclean) 
apm                     9768   1 (autoclean) 
mousedev                3832   0 (unused)
hid                    22372   0 (unused)
input                   3168   0 [mousedev hid]
af_packet              13544   0 (autoclean) 
nls_iso8859-1           2844   2 (autoclean) 
nls_cp437               4348   2 (autoclean) 
serial                 52100   1 (autoclean) 
usb-ohci               18120   0 (unused)
usbcore                57824   1 [hid usb-ohci]
pcnet_cs               10884   1
8390                    6400   0 [pcnet_cs]
crc32                   2816   0 [8390]
ds                      6536   2 [pcnet_cs]
i82365                 12580   2
pcmcia_core            39840   0 [pcnet_cs ds i82365]
rtc                     7036   0 (autoclean) 
cloop                   8740   2
ide-cd                 28512   0
ide-scsi                8816   0
root@box:~# lspci -v
0000:00:00.0 0600: 1179:0601 (rev 27)
	Flags: bus master, medium devsel, latency 0

0000:00:04.0 0300: 102c:00e4 (rev c2)
	Flags: stepping, medium devsel
	Memory at fe000000 (32-bit, non-prefetchable) [size=16M]
	Expansion ROM at  [disabled] [size=256K]

0000:00:0b.0 0c03: 1033:0035 (rev 01) (prog-if 10)
	Flags: bus master, medium devsel, latency 64, IRQ 11
	Memory at fdfff000 (32-bit, non-prefetchable) [size=4K]

root@box:~# cat /proc/interrupts 
           CPU0       
  0:     129373          XT-PIC  timer
  1:        390          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  3:        759          XT-PIC  pcnet_cs
  4:       2079          XT-PIC  serial
  6:         21          XT-PIC  floppy
  8:          0          XT-PIC  rtc
 11:          0          XT-PIC  usb-ohci
 14:       4498          XT-PIC  ide0
 15:          2          XT-PIC  i82365
NMI:          0 
LOC:          0 
ERR:          1
MIS:          0
root@box:~# cat /proc/ioports 
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
02f8-02ff : serial(auto)
0300-031f : pcnet_cs
03c0-03df : vga+
03e0-03e1 : i82365
03f2-03f5 : floppy
03f6-03f6 : ide0
03f7-03f7 : floppy DIR
03f8-03ff : serial(auto)
0cf8-0cff : PCI conf1
root@box:~# dmesg
Linux version 2.4.26 (root@Knoppix) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 SMP Sa Apr 17 19:33:42 CEST 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000002020000 (usable)
 BIOS-e820: 00000000fffe0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
32MB LOWMEM available.
On node 0 totalpages: 8224
zone(0): 4096 pages.
zone(1): 4128 pages.
zone(2): 0 pages.
DMI not present.
ACPI: Unable to locate RSDP
Kernel command line: ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 initrd=minirt24.gz nomce quiet BOOT_IMAGE=knoppix BOOT_IMAGE=linux24 vga=normal restore=hda5
No local APIC present or hardware disabled
Initializing CPU#0
Detected 132.634 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 264.60 BogoMIPS
Memory: 29392k/32896k available (1371k kernel code, 3116k reserved, 561k data, 140k init, 0k highmem)
Dentry cache hash table entries: 8192 (order: 4, 65536 bytes)
Inode cache hash table entries: 4096 (order: 3, 32768 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 16384 (order: 4, 65536 bytes)
Intel Pentium with F0 0F bug - workaround enabled.
CPU:     After generic, caps: 008001bf 00000000 00000000 00000000
CPU:             Common caps: 008001bf 00000000 00000000 00000000
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch [removed]
mtrr: detected mtrr type: none
CPU:     After generic, caps: 008001bf 00000000 00000000 00000000
CPU:             Common caps: 008001bf 00000000 00000000 00000000
CPU0: Intel Pentium MMX stepping 03
per-CPU timeslice cutoff: 160.11 usecs.
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Waiting on wait_init_idle (map = 0x0)
All processors have done init_idle
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xfdcf1, last bus=21
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
pty: 256 Unix98 ptys configured
Floppy drive(s): fd0 is 1.44M
FDC 0 is an 8272A
RAMDISK driver initialized: 16 RAM disks of 100000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
hda: TOSHIBA MK1301MAV, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: attached ide-disk driver.
hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
hda: task_no_data_intr: error=0x04 { DriveStatusError }
hda: 2654280 sectors (1359 MB) w/128KiB Cache, CHS=658/64/63
Partition check:
 hda: hda1 hda2 < hda5 hda6 >
ide: late registration of driver.
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 2048)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 183k freed
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Unable to identify CD-ROM format.
VFS: Can't find ext2 filesystem on dev ide0(3,0).
FAT: bogus logical sector size 64543
VFS: Can't find a valid FAT filesystem on dev 03:00.
Unable to identify CD-ROM format.
VFS: Can't find ext2 filesystem on dev ide0(3,1).
cloop: Initializing cloop v2.01
cloop: loaded (max 8 devices)
cloop: /cdrom/KNOPPIX/KNOPPIX: 1863 blocks, 65536 bytes/block, largest block is 65552 bytes.
ISO 9660 Extensions: RRIP_1991A
Freeing unused kernel memory: 140k freed
Real Time Clock Driver v1.10f
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
Intel ISA PCIC probe: 
  Intel i82365sl B step ISA-to-PCMCIA at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: none
    host opts [1]: none
    ISA irqs (scanned) = 3,4,5,7,9,10,12,15 status change on irq 15
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x220-0x22f 0x2f8-0x2ff 0x330-0x337 0x370-0x37f 0x388-0x38f 0x3f8-0x3ff 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0x0d0000-0x0dffff: clean.
eth0: NE2000 Compatible: io 0x300, irq 3, hw_addr 00:40:33:A0:B9:C0
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 19:48:59 Apr 17 2004
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: deregistering driver usbdevfs
usb.c: deregistering driver hub
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xc308b000, IRQ 11
usb-ohci.c: usb-00:0b.0, NEC Corporation USB
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usbdevfs: remount parameter error
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected
Adding Swap: 66492k swap-space (priority -1)
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik [removed]
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
apm: BIOS version 1.2 Flags 0x02 (Driver version 1.16)
spurious 8259A interrupt: IRQ7.
root@box:~# exit

Script done on Mon Oct 17 20:51:32 2005

.

Countergeocities archive

.

.

---------------- 1 [removed]